Reporting Lag
Incident Report for LKQD
Resolved
Reporting lag has caught up, this issue is now closed.
Posted May 09, 2016 - 22:24 PDT
Investigating
Reporting is currently delayed by approximately 30 minutes, LKQD Engineers are investigating.
Posted May 09, 2016 - 21:08 PDT