Reporting Data Lag
Incident Report for LKQD
Resolved
Reporting lag resolved.
Posted Oct 25, 2016 - 09:25 PDT
Investigating
Reporting Data is currently 35 minutes behind. LKQD Engineering is investigating and will post updates. Ad serving and ad tracking are not affected.
Posted Oct 25, 2016 - 07:41 PDT