Reporting Lag
Incident Report for LKQD
Resolved
This incident has been resolved.
Posted Jan 18, 2016 - 19:51 PST
Monitoring
Reporting is currently lagging by 30 minutes while we complete routine infrastructure maintenance, ad serving is not affected.
Posted Jan 18, 2016 - 17:13 PST