Reporting Lag
Incident Report for LKQD
Resolved
Reporting lag is currently resolved, we will continue to monitor and post updates if the issue reoccurs.
Posted Mar 17, 2016 - 15:14 PDT
Investigating
We're currently investigating longer than normal reporting delays. Ad serving is not affected.
Posted Mar 16, 2016 - 23:27 PDT