Reporting Lag
Incident Report for LKQD
Resolved
UI Reporting lag has been resolved.
Posted Dec 28, 2015 - 09:56 PST
Investigating
We are currently investigating UI reporting lag. Ad serving is not affected.
Posted Dec 28, 2015 - 09:24 PST